Forum > DCS World

Running Tacview on a DCS World 1.5.8 Multiplayer Server


I run the Aerobatics Online DCS World servers.  For all versions of DCS World released after the harrier, I am unable to create Tacview recordings of player activity.  My previous implementation was to have an entry in the Scripts/Export.lua citing:
   local Tacviewlfs=require('lfs');dofile(Tacviewlfs.writedir()..'Scripts/TacviewExportDCS.lua')
In addition, the TacviewExportDCS.lua existed in Scripts as well.  This version was from Tacview 1.5.2 and has worked until now.  I did not have the actual Tacview program installed on my DCS World servers as it was not necessary for file generation.

This capture method stopped working with the release of 1.5.8 and 2.2.0.  Simply moving those files to Scripts/Hooks (and updating paths) did not solve the issue.  I downloaded Tacview 1.6.4, made the entry into the Options.lua, and replicated the file structure in the Saved Games\DCS folder from the install folder, and while it does show in the mission and the DCS logs that Tacview is running, it produces ~1kb track files that are essentially empty.

I downloaded Tacview 1.7.0 Beta 4 and files in the installation folder, I created the following file structure in my Saved Games\DCS folder:
Saved Games\DCS\Mods\Tech\Tacview\ -> all directories and files copied over.
Saved Games\DCS\Scripts\Hooks\TacviewGameGUI.lua
Saved Games\DCS\Scripts\Export.lua
Saved Games\DCS\Scripts\TacviewGameExport.lua
Saved Games\DCS\Scripts\TacviewGameGUI.lua -> duplicate file, with a different date stamp?

This time, it creates files with data, but opening the ACMI file produces the error:  "The file format of [filename] is not supported.  Check the official website to know if there is a newer version of Tacview or another edition which can read this file."  Examining the ACMI file, it looks like it's still compressed, but it's not a valid zip file.

Where am I going wrong with my installation or configuration?

You have done the right thing: Installing the latest beta of Tacview 1.7.0 should fix the export for the new versions of DCS World.

Now, it looks like that your acmi files are corrupted because of a crash in DCS World at exit. If this happens often, you can ask the ACMI exporter to not compress the acmi files. Uncompressed files can always be read by Tacview, even if they are incomplete/corrupted by a DCS World crash.

Go in DCS World Special / Tacview options and set the file compression to none, this should fix your problem. (The option panel should be properly displayed with Tacview 1.7.0 beta 3 exporter).

Yup, that was the solution.  I've got it recording Tacview tracks for both 1.5.8 and 2.2.0 again.  To simplify the instructions for anyone else having this issue, here is my setup to generate tracks on the server as an automatic process.

I am using Tacview 1.6.4.  Tacview can be installed on the server, but it is not necessary; however, you will need access to the installation folder for some required files.  The example I'm giving is for 1.5.8, but this will work for 2.2.0 by modifying the path.  On the server:
1)  Create a Documents\Tacview directory if one does not already exist.
2)  Copy the Program Files (x86)\Tacview\DCS folder content (after installing Tacview somewhere) to Saved Games\DCS
3)  Create a Hooks folder in Saved Games\DCS and move the TacviewGameGUI.lua file to this location.
4)  Edit the Saved Games\DCS\Config\options.lua file and add the following entry:
["Tacview"] = {
         ["bookmarkShortcut"] = 0,
         ["dataRecordingEnabled"] = true,
         ["debugModeEnabled"] = true,
         ["playbackDelay"] = 0,
         ["profilingPeriod"] = 60,
         ["recordClientsSessionsEnabled"] = true,
         ["tacviewBookmarkShortcut"] = 0,
         ["tacviewCompressionLevel"] = 0,
         ["tacviewDataRecordingEnabled"] = true,
         ["tacviewDebugModeEnabled"] = false,
         ["tacviewPlaybackDelay"] = 600,
         ["tacviewProfilingPeriod"] = 600,
         ["tacviewRealTimeTelemetryPort"] = "42674",
         ["tacviewRecordClientsSessionsEnabled"] = false,
         ["tacviewRemoteControlPort"] = "42675",

If automatically killing the DCS process on a schedule to force server restarts, make sure that ["tacviewCompressionLevel"] = 0 to ensure the file isn't corrupted.  For a fully manual implementation, that can be set to 1 which will keep file sizes smaller.

That's it.  The server will automatically record Tacview files to record player activity.


[0] Message Index

Go to full version